Journalistiek

Onpartijdig, onafhankelijk nieuws, uitsluitend in dienst van het branchebelang.

PHP 5.3.0 nader bekeken

  • Door
  • Randy ten Have
  • geplaatst op
  • 15 juli 2009 08:03 uur

php-logoEind juni is PHP 5.3 uitgekomen, een nieuwe release in de PHP 5 branch. Hoewel de release announcement laat lijken alsof het allemaal héél spannend is, valt het nog best wel  mee. Zowel voor de hoster als de klant. ISPam.nl vroeg hoster PCextreme om te kijken wat nu de wijzigingen waren voor hoster en klant.

In de release announcement valt onder andere te lezen:
? Support for namespaces
? Under the hood performance improvements
? More consistent float rounding

Dit zijn 3 punten die opvallen en zowel voor de hoster als de klant voordelen opleveren. Maar is er dan echt niets te melden wat tot veel helpdesk vragen kan leiden? Jawel! In PHP 5.3 zijn “magic_quotes” en “register_globals” deprecated geworden, die staat ook met grote letters op php.net: “This feature has been DEPRECATED as of PHP 5.3.0 and REMOVED as of PHP 6.0.0. Relying on this feature is highly discouraged.”

Naar mijn idee is dit een goede stap vanuit PHP, want moet een programmeertaal voor jou je input escapen? (zoals magic_quotes deed) Of is dit voor de programmeur? Heeft hij/zij niet te bepalen wat er met de input moet gebeuren? Uiteraard was magic_quotes uit te zetten, echter heeft de introductie er wel voor gezorgd dat veel programmeurs niet eens nadachten over input controle, met alle spambots van dien..

Ook het verwijderen (deprecated maken) van register_globals is een goede stap in de juiste richting. Het aanzetten van register_globals was (en is nog steeds!) een groot gevaar wanneer er in de code niet genoeg rekening mee wordt gehouden, daarnaast was het weer iets wat PHP voor je deed, wat eigenlijk een programmeur zelf moet regelen.

Als hoster kan je dus gaan merken dat er klanten zullen komen die nu ineens een notice van PHP krijgen dat ze nog register_globals of magic_quotes gebruiken, wees daar op bedacht. Onder andere osCommerce is nog steeds afhankelijk van register_globals, van klanten die nog osCommerce gebruiken zijn dus wel support aanvragen te verwachten.

Echt grote veranderingen zitten er dus niet in PHP 5.3, deze zullen we pas gaan krijgen in PHP 6, maar dat is nu nog even toekomst muziek.

Om het voor Ubuntu beheerders makkelijk te maken om PHP 5.3 te installeren op hun servers heeft een collega van mij .deb files gemaakt die zijn te installeren op Ubuntu 8.04. Stel hiervoor als mirror in: deb http://pcx.apt-get.eu/ubuntu hardy unofficial. Aan pakketen voor Ubuntu 9.04 wordt nog gewerkt.

Mark, 15 juli 2009 9:04 am

@Randy: de belangrijkste wijzigingen die hier genoemd worden waren al langer bekend/aangekondigt.

Wido, 15 juli 2009 9:23 am

Verder is PHP 5.3 ook helemaal niet zo spannend, het klinkt enger dan het echt is.

Persoonlijk zie ik veel voordeel in de float rounding, want daar heb ik nogal wat ruzie mee gehad. Zo werd de uitkomst van een berekening 9.94 terwijl het 9.95 moest zijn.

Als je met prijzen werkt in een systeem is het ook het slimste om alles in centen op te slaan en te verwerken, pas op het laatste moment door 100 delen.

Maurice, 15 juli 2009 11:00 am

PHP 5.3 zullen een gros van de hosters nog niet kunnen aanbieden door Direct Admin controlpanel welke nog niet compatible is :)

Wido, 15 juli 2009 11:14 am

Het kan er prima naast door middel van CGI? Zo doen wij het ook, PHP 5.2 als mod_php en PHP 5.3 als CGI er naast.

Sebastiaan Stok, 15 juli 2009 7:52 pm

Het probleem waar ik tegen aanloop bij een upgrade is de ondersteuning van Ioncude loader...

Verder heb ik geen problemen kunnen ontdekken in de eigen websites (en wat problemen gaf, is inmiddels opgelost).

Wat wel echt te gek is http://nl3.php.net/manual/en/book.intl.php !! dat is naast namespaces gewoon hemels.

Sebastiaan Stok, 15 juli 2009 9:54 pm

Hier de verklaring van Ioncube zelf.
http://forum.ioncube.com/viewtopic.php?t=1856&highlight=php+5+3

gerwin, 16 juli 2009 9:27 am

Ioncube maar ook ZendOptimizer... En dat gaat ook even duren :(

Sebastiaan Stok, 16 juli 2009 10:38 am

Zelf kan ik gewoon de Zend Optimizer laden zonder een foutmelding of iets. Of hij werkt heb ik nog niet getest.

gerwin, 16 juli 2009 1:14 pm

@sebastiaan
Dat is interesting, maar denk dat je wel tegen problemen aan gaat lopen. Gebruik je de 5.2 module?

Bart, 16 juli 2009 1:23 pm

Eerst maar even testen lijkt me, geen foutmelding zegt immers niks

Sebastiaan Stok, 16 juli 2009 1:31 pm

Nu krijg ik wel een foutmelding, kennelijk had ik iets fout gedaan.

Nu moet ik toegeven dat ik gewoon had uitgevoerd via "./sapi/cli/php -n -z /usr/local/Zend/lib/ZendExtensionManager.so" in source folder. En niet via een php.ini bestand.
Maar ik krijg nu gewoon een foutmelding: Cannot load Zend Extension Manager - it was built with configuration 1.2.0, whereas running engine is API220090626,NTS

Feedback!
Fill out my online form.
Laatste reacties

Bedankt voor het succes van ISPam.nl
Koen Stegeman, Editor-in-Chief & founder Hostingjournalist.com: Jammer Arnout, maar je hebt een mooie bijdrage aan de hosting industrie geleverd, en dat jaren lang....

Bedankt voor het succes van ISPam.nl
Dillard Blom: Jammer dat een 'instituut' verdwijnt, en daarmee een bron van informatie over actuele zaken (en opin...

Bedankt voor het succes van ISPam.nl
L.: Uit automatisme kijk ik toch nog steeds elke dag naar ispam.nl, toch de hoop dat er nog een berichtj...

Bedankt voor het succes van ISPam.nl
Toni Donkers: Arnout bedankt! ik ga het missen dat is een feit!

Bedankt voor het succes van ISPam.nl
Marcel Stegeman: Ik zie het nu pas. Inderdaad jammer maar ik kijk nu al uit naar het volgende project.